Required packages to build SageMath 9.0 on Ubuntu

http://loco.ubuntu.com/media/images/cof_orange_hex1.png

Here is the minimal list of Ubuntu packages to install in order to build SageMath from sources (this is for Ubuntu 18.04):

In addition, it is recommended to install

Besides, to make SageMath use a maximum of system (Ubuntu) packages instead of building its own versions, see here.

For more details, see the Prerequisites section of Sage Installation Guide.

Since version 9.1, Sage generates the lists of required prerequisites in the installation manual automatically. Do not update this wiki page. Automatically updating the list of recommended system packages is the subject of https://trac.sagemath.org/ticket/29557

prerequisites/Ubuntu (last edited 2020-05-04 18:36:01 by mkoeppe)