Differences between revisions 15 and 16
Revision 15 as of 2008-05-20 02:04:10
Size: 2338
Editor: JasonBandlow
Comment:
Revision 16 as of 2008-05-20 18:26:29
Size: 3721
Editor: JasonBandlow
Comment:
Deletions are marked like this. Additions are marked like this.
Line 2: Line 2:
== Words (there is more to look at here) ==
Line 6: Line 7:
== Combinatorial* (not considered very carefully) ==
Line 9: Line 11:
== Combinations ==
 * Looks good! (Just recording here that it was looked at).
== Compositions ==
Line 10: Line 15:
 * Composition will all entries with '0' parts (but not, for example, negative parts). It's not clear that all methods make sense when '0' parts are allowed.
Line 15: Line 21:
== Dyck Words ==
Line 22: Line 29:
== Integer Vectors ==
Line 24: Line 32:
== Lyndon Words ==
Line 25: Line 34:
 * LyndonWords are not defined in the docstring  * LyndonWords? does not define Lyndon words
== Mul
tichooseNK ==
Line 28: Line 38:
 * Necklaces are not defined in the docstring
 * PartitionsGreatestEQ, PartitionsGreatestLE, PartitionsInBox are redundant with Partitions
 * For the following comments, let p be a partition:
== Necklaces ==
 * Necklaces? does not define necklaces
== Partitions ==
 * PartitionsGreatestEQ, PartitionsGreatestLE, PartitionsInBox are redundant with options passed to Partitions
 * The doc for Partition should point out that < compares lexicographically
 * The doc for Partition says 'Sage uses the English convention...' this should be expanded and mention 0-indexing; in fact it should also mention that partitions can be interpreted as diagrams
 * The partition* stuff is all redundant
 * (For the following comments, let p be a partition)
Line 32: Line 47:
 * p.arm_legs_coeff() is not explained  * p.arm_legs_coeff() is not defined
Line 36: Line 51:
 * An example should be given for the q,t-analog of p.centralizer_size()  * An reference, definition, or at least an example should be given for the q,t-analog of p.centralizer_size()
 * p.character_polynomial() deserves a reference
 * p.dominate() should be called p.dominated_partitions() (or something more clear)
 * p.down(), p.down_list(), p.up(), p.up_list() could have better names? (restrict/induce? is there a convention for a generator vs a list? is this too redundant?)
 * is p.evaluation() a standard name?
 * p.ferrers_diagram() is basically redundant with p.pp()
 * p.generalized_pochhammer_symbol? needs a definition and, better, a reference
 * p.hook_lengths() should be called p.hook_length_tableau()
 *

Weirdness

Words (there is more to look at here)

  • sage.combinat.word is not imported by default
  • word.symmetric_group_action_on_values does not naturally belong in word
  • word.standard should be called word.standardization
  • word.charge returns the cocharge

Combinatorial* (not considered very carefully)

Combinations

  • Looks good! (Just recording here that it was looked at).

Compositions

  • Compositions has no option for allowing '0' parts (which are often useful) (IntegerVectors does this. There should be a pointer.)

  • Composition will all entries with '0' parts (but not, for example, negative parts). It's not clear that all methods make sense when '0' parts are allowed.
  • Composition.conjugate() is not explained
  • Composition.descents() is not explained
  • Composition.major_index() doc-string says it is the sum of the descents. This is not true for the given example.
  • Composition.refinement() is not explained
  • SignedCompositions has no corresponding class SignedComposition

Dyck Words

  • DyckWords? does not define Dyck words

  • DyckWord.b_statistic() is not explained

  • DyckWord.height() is not explained

  • DyckWord.peaks() is not explained

  • DyckWord.to_noncrossing_partition() could use a better reference

  • DyckWord.to_tableau is not explained

  • DyckWord.to_* for * in {ordered_tree, triangulation} is not implemented. Warning: Implementing bijections between Catalan objects can be a never-ending task.

Integer Vectors

Lyndon Words

MultichooseNK

  • MultichooseNK has no useful documentation
  • The name MultichooseNK does not compare well with Combinations, though they do very similar things

Necklaces

  • Necklaces? does not define necklaces

Partitions

  • PartitionsGreatestEQ, PartitionsGreatestLE, PartitionsInBox are redundant with options passed to Partitions

  • The doc for Partition should point out that < compares lexicographically

  • The doc for Partition says 'Sage uses the English convention...' this should be expanded and mention 0-indexing; in fact it should also mention that partitions can be interpreted as diagrams
  • The partition* stuff is all redundant
  • (For the following comments, let p be a partition)
  • p.arm_lengths() should be called.p_arm_length_tableau()
  • p.arm_legs_coeff() is not defined
  • p.associated() is an alias for p.conjugate(). Is it necessary?
  • p.atom() is not defined
  • p.boxes() would be better called p.cells()
  • An reference, definition, or at least an example should be given for the q,t-analog of p.centralizer_size()
  • p.character_polynomial() deserves a reference
  • p.dominate() should be called p.dominated_partitions() (or something more clear)
  • p.down(), p.down_list(), p.up(), p.up_list() could have better names? (restrict/induce? is there a convention for a generator vs a list? is this too redundant?)
  • is p.evaluation() a standard name?
  • p.ferrers_diagram() is basically redundant with p.pp()
  • p.generalized_pochhammer_symbol? needs a definition and, better, a reference
  • p.hook_lengths() should be called p.hook_length_tableau()

combinat/Weirdness (last edited 2018-11-06 19:45:34 by chapoton)