mpfi.spkg

Description

This is MPFI from http://gforge.inria.fr/projects/mpfi/

PACKAGE MAINTAINER: Carl Witty (cwitty (AT)newtonlabs.com)

Changelog

mpfi-1.3.4-cvs20071125.p7 (Michael Abshoff, May 18th, 2008)

mpfi-1.3.4-cvs20071125.p6 (William Stein, May 16, 2008)

mpfi-1.3.4-cvs20071125.p5 (Michael Abshoff, Jan. 31st, 2008)

mpfi-1.3.4-cvs20071125.p4 (Michael Abshoff)

# Checks for MPFR lib (Before GMP!) if  test "$with_mpfr_lib"  then

else

fi

# Checks for GMP lib if  test "$with_gmp_lib"  then

else

fi

mpfi-1.3.4-cvs20071125.p3 (Michael Abshoff)

Clean up the test of the changelog

1. I have changed two functions:

First, mpfi_set_str() in mpfi/src/mpfi_io.c. (The original version was very wrong; I fixed off-by-one errors, fixed a buffer overflow, and fixed it so that it could return precise intervals on precisely representable inputs, instead of always making an interval containing two floats.) The original version of the file is at mpfi/src/mpfi_io.c.ORIG

Second, mpfi_diam_rel() in mpfi/src/mpfi.c: I changed line 598 from

to

2. I (=William Stein) changed configure.ac to only build src and not tests or doc, since building tests on some systems fails. Of course, it would be better to fix building of tests. I put the changed version of configure.ac in the patches directory. After changing it, I ran

in the src directory.

3. Carl Witty 2007-11-01 a. Fixed mpfi_ui_sub, by applying a patch posted by Paul Zimmerman to the MPFI bug tracker. b. Fixed the infinite loop in mpfi_cmp_sym_pi() (fixes the infinite loop in mpfi_cos(), reported as MPFI bug# 1868 and Sage issue #389.

4. Carl Witty 2007-11-25 MPFI upstream is alive again! I'm switching to the current upstream CVS version as of today, fetched with:

cvs -d :pserver:[email protected]:/cvsroot/mpfi login cvs -d :pserver:[email protected]:/cvsroot/mpfi checkout mpfi mv mpfi src cd src ./autogen.sh

This version includes all the patches from the Sage spkg (or equivalent code), and fixes several additional bugs. (So I removed the patches/ directory, and the corresponding lines in spkg-install.) Also, this new version installs both shared and static libraries.

5. Carl Witty 2007-11-29 The previous version did not compile on OSX 10.4 Intel. I think the problem may be with src/autogen.sh, which makes ltmain.sh, config.sub, and config.guess be symlinks instead of files; so we get whatever versions of these files happen to be already installed on the user's computer.

So I've replaced these three symlinks with the corresponding files, and we'll see if that fixes the problem.

6. Carl Witty 2007-12-01 The previous version required "autoheader" (part of autoconf). I've copied in a new version of src/missing, and touched src/mpfi_config.h.in; I believe that either of these changes would suffice to fix the problem.

spkg/mpfi (last edited 2008-12-27 21:30:45 by MichaelAbshoff)